ESPHome: xtensa-lx106-elf-g++: not found

SONOFF NSPanel
SONOFF NSPanel
69,49 €

Für alle die längere Zeit Ihr ESPHome nicht aktualisiert haben und nun nach einem Update die folgende Fehlermeldung haben, habe ich hier wahrscheinlich die Lösung.

--------------------------------------------------------------------------------
HARDWARE: ESP8266 80MHz, 80KB RAM, 4MB Flash
LDF: Library Dependency Finder -> https://bit.ly/configure-pio-ldf
Dependency Graph
|-- <ESPAsyncTCP-esphome> 1.2.3
|-- <ESPAsyncWebServer-esphome> 2.1.0
|   |-- <ESPAsyncTCP-esphome> 1.2.3
|   |-- <Hash> 1.0
|   |-- <ESP8266WiFi> 1.0
|-- <DNSServer> 1.1.1
|-- <ESP8266WiFi> 1.0
|-- <ESP8266mDNS> 1.2
Compiling /data/tagnacht-licht/.pioenvs/tagnacht-licht/src/esphome/components/api/api_connection.cpp.o
sh: 1: xtensa-lx106-elf-g++: not found
Compiling /data/tagnacht-licht/.pioenvs/tagnacht-licht/src/esphome/components/api/api_frame_helper.cpp.o
sh: 1: xtensa-lx106-elf-g++: not found
Compiling /data/tagnacht-licht/.pioenvs/tagnacht-licht/src/esphome/components/api/api_pb2.cpp.o
sh: 1: xtensa-lx106-elf-g++: not found
 [/data/tagnacht-licht/.pioenvs/tagnacht-licht/src/esphome/components/api/api_connection.cpp.o] Error 127
 [/data/tagnacht-licht/.pioenvs/tagnacht-licht/src/esphome/components/api/api_frame_helper.cpp.o] Error 127
 [/data/tagnacht-licht/.pioenvs/tagnacht-licht/src/esphome/components/api/api_pb2.cpp.o] Error 127
Compiling /data/tagnacht-licht/.pioenvs/tagnacht-licht/src/esphome/components/api/api_pb2_service.cpp.o
sh: 1: xtensa-lx106-elf-g++: not found
 [/data/tagnacht-licht/.pioenvs/tagnacht-licht/src/esphome/components/api/api_pb2_service.cpp.o] Error 127
========================== [FAILED] Took 2.15 seconds ==========================


Das Problem

Und zwar liegt das Problem wahrscheinlich darin, dass Ihr noch die alte ESPHome Integration aus den Home Assistant Community Add-ons verwendet, anstelle des mit dem Februar 2022 Update eingeführten nun direkt integrierten Add-ons.
ESPHome gehört nämlich ab sofort zum Standard in Home Assistant. Das Add-on aus „Home Assistant Community Add-ons“ Repository wird nicht länger unterstützt und führt unter anderem zu oben genanntem Fehler, wenn man versucht ein Projekt zu installieren.

Die Lösung

Die Fehlerbehebung ist eigentlich ganz einfach. Entfernt einfach das alte ESPHome Add-on aus eurem Home Assistant und installiert anschließend das aktuelle Addon.

Mit Klick auf den Button könnt Ihr das neue Addon direkt in Euer Home Assistant installieren. So könnt Ihr euch auch sicher sein, dass Ihr das richtige erwischt.

Alle weiteren Informationen zum neuen ESPHome AddOn findet Ihr im Februar 2022 Changelog unter:
https://esphome.io/changelog/2022.2.0.html